S-1 Teknik Informatika


Pembahasan Ujian Tengah Semester (UTS) 2010/2011 Mata Kuliah Jaringan Komputer

13 Apr

A. SOAL PEMAHAMAN MATERI

Soal 1: Jelaskan jumlah secara rinci alamat IPv4 yang diperbolehkan digunakan di jaringan Internet dan sebutkan alamat-alamat IPv4 yang tidak boleh digunakan di jaringan Internet. Berikan alasan kenapa alamat IP tertentu (khusus) tidak boleh digunakan di jaringan Internet!

Pembahasan :

Dengan memperhatikan kapasitas yang digunakan pada pengalamatan IPv4 adalah 32 bit maka secara umum dapat dikatakan jumlah IPv4 adalah 232 = 4.294.967.296 IP Address. Akan tetepi tidak semua alamat IP bisa dipergunakan begitu saja dalam pengalamatan di jaringan. Pengalamatan jaringan harus memperhatikan aturan-aturan pengalamatan IPv4 yang sudah ditentukan yaitu tentang pengaturan berdasarkan IP Class dan IP Khusus. Pengaturan Kelas IPv4 yaitu :

Class A : 1.0.0.0 s.d 126.255.255.254,

Class B : 128.0.0.0 s.d 191.255.255.254,

Class C : 192.0.0.0 s.d 223.255.255.254,

Class D : 224.0.0.0 s.d 239.255.255.255,

Class E : 240.0.0.0 s.d 254.255.255.254 .
Dari pembagian IP Class tersebut masih harus memperhatikan tentang beberapa IP yang tidak dipergunakan dalam pengalamatan terminal yaitu Class D sebagai Alamat Multiclass Address, Class E untuk di cadangkan, IP Loopback, Broadcast dan IP Private.

Dengan demikian alamat IPv4 yang digunakan dalam pengalamatan hanya IP Class A, B dan C. Karena IP Class A, B dan C tersebut masih terdiri dari IP Loopback, IP Address Private, alamat Jaringan dan Alamat local broadcast maka secara keseluruhan jumlah alamat IPv4 yang dapat digunakan dalam jaringan dapat diuraikan sebagai berikut :

Jumlah bit untuk alamat jaringan kelas A adalah 8bit dikurangi 1bit, sehingga hasilnya 7bit. 1bit pengurangan tersebut sudah merupakan ketentuan IP class A karena untuk IP class A sudah ditentukan bahwa bit pertama pada oktet pertama adalah nol (0xxxxxxx). Di dalam kelas A terdapat IP pertama nol tidak mungkin digunakan, dan loopback address (127.x.x.x). Dengan demikian total alamat jaringan kelas A adalah  (27– 2) = 126. Selain itu untuk IP Class A juga terdapat satu alamat jaringan Private. Sedangkan Class B jumlah bit jaringannya adalah 16bit dikurangi 2bit karena bit pertama class B adalah satu nol (10xxxxxx), dengan total alamat jaringan adalah 214. Sedangkan IP class C adalah 24 bit dikurangi 3bit sehingga totalnya adalah 221.

Class A : ((27-2)x(224-2)) – (1 x(224-2)) = ((128-2) X (16.777.216 – 2)) – (1x(16.777.216 – 2) = 2.113.929.216 – 16.777.214 = 1.947.151.750

Class B : (214x(216-2))-(16x(216-2)) = (16.384 x (65.536 – 2 )) – (16 x ( 65.536 – 2 )) = 1.073.709.056 – 10.488.576 = 10.63.220.480

Class C : (221x(28-2)) – ( 256 x (28-2)) = (2.097.152 x 254) – (256 x 254) = 532676608 – 65024 = 532.676.608

Sehingga Total Alamat IPv4 yang dapat digunakan di jaringan Internet adalah Total Class A (1.947.151.750) + Total Class B (10.63.220.480) + Total Class C (532.676.608) = 3.543.048.838.

Sedangkan jumlah alamat IPv4 yang tidak dapat digunakan dalam pengalamatan host dalam jaringan adalah 4.294.967.296 – 3.543.048.838 = 751.918.458 Alamat IP atau kurang lebih 17%.

Soal 2: Dalam proses komunikasi antara satu terminal dengan terminal lain dalam jaringan komputer suatu datagram mengalami proses fragmentasi. Jelaskan proses fragmentasi dan kenapa proses fragmentasi tersebut terjadi!

Pembahasan :

Suatu datagram akan ter-fragmentasi jika ukuran dari datagram tersebut lebih besar dari Maximum Transfer Unit (MTU) perangkat jaringan. Ketika Router menerima Protocol Data Unit (PDU) lebih besar dari MTU simpul jaringan berikutnya, pada IPv4 dimungkinkan terjadi dua pilihan. Drop PDU dan mengirim pesan melalui ICMP yang menjelaskan bahwa kondisi packet terlalu besar atau di fragmentasi sesuai dengan ukuran simpul jaringan berikutnya kemudian dikirimkan. Kemudian simpul yang menerima paket IP terfragmentasi tersebut akan melakukan re-assembly datagram untuk dikomunikasikan pada protokol layer lebih tinggi.

 

Soal 3: Bagaimanakah perincian dari suatu alamat jaringan yang meliputi; alamat IP yang bisa digunakan, dan alamat broadcast tiap segmentasi jaringan jika sebuah alamat jaringan 192.168.1.0/24 diubah menjadi 4 sub jaringan dengan tujuan untuk mengakomodasi pengalamatan jaringan antara 20 sampai 30 alamat IP di masing-masing sub jaringan.

Pembahasan :

Satu alamat jaringan 192.168.1.0/24 dibagi menjadi 4 sub jaringan, dengan ketentuan maksimum IP dalam jaringan adalah 30 alamat IP. Dalam kasus ini dapat dikerjakan dengan menggunakan konsep subnetting conventional karena jumlah alamat IP dalam masing-masing jaringan sama. Karena menggunakan conventional subnet maka Subnet Zero dan Subnet-ones tidak diijinkan untuk digunakan sehingga dengan memperhatikan kebutuhan jumlah host yang harus terpenuhi 30 alamat IP per subnet, maka dapat digunakan 5 bit host karena untuk memenuhi 30 ip per subnet yang paling mendekati adalah 25 = 32, sehingga pembagian jaringannnya adalah sebagai berikut :

subnet-1. 192.168.1.0/27 (Subnet-Zero)

subnet-2. 192.168.1.32/27

subnet-3. 192.168.1.64/27

subnet-4. 192.168.1.96/27

subnet-5. 192.168.1.128/27

subnet-6. 192.168.1.160/27

subnet-7. 192.168.1.192/27

subnet-8. 192.168.1.224/27 (Subnet-Ones)

Dari 8 subnet tersebut subnet zero dan subnet ones tidak boleh digunakan sehingga yang dapat digunakan adalah subnet ke-2 sampai dengan subnet ke-7. Sedangkan kebutuhan hanya 4 subnet, maka dapat digunakan mulai subnet ke-2 sampai dengan subnet ke-5, atau boleh subnet lain selain subnet-1 dan subnet-8.

Subnet-2. 192.168.1.32/27

Alamat jaringan = 192.168.1.32

Range IP Host = 192.168.1.33 s.d 192.168.1.62

Alamat IP Broadcast = 192.168.1.63

 

Subnet-3. 192.168.1.64/27

Alamat jaringan = 192.168.1.64

Range IP Host = 192.168.1.65 s.d 192.168.1.94

Alamat IP Broadcast = 192.168.1.95

Subnet-4. 192.168.1.96/27

Alamat jaringan = 192.168.1.96

Range IP Host = 192.168.1.97 s.d 192.168.1.126

Alamat IP Broadcast = 192.168.1.127

Subnet-5. 192.168.1.128/27

Alamat jaringan = 192.168.1.128

Range IP Host = 192.168.1.129 s.d 192.168.1.158

Alamat IP Broadcast = 192.168.1.159

 

B. SOAL STUDI KASUS

Sebuah usaha game online yang memiliki 42 unit terminal jaringan sering mengalami kendala dalam hal konektifitas, yakni jaringan tiba-tiba lambat bahkan sering kali jaringan tersebut down. Jika seluruh perangkat jaringan yang ada di lantai 2 dan 3 di restart jaringan tersebut normal kembali. Peralatan jaringan pada game online tersebut terdiri dari 1 switch di lantai satu yang terhubung dengan HUB di lantai 2 dan HUB di lantai 3 terhubung pada salah satu port perangkat jaringan (HUB) di lantai 2. Koneksi ke jaringan Internet melalui router yang ada di lantai 1 dan terhubung ke suatu ISP sebut saja J-Net menggunakan koneksi broadband. Masing – masing terminal tersebar di ke tiga lantai dengan jumlah yang sama. Perangkat Router tersebut memiliki 4 koneksi ethernet, 1 port terhubung ke ISP dan sat port terhubung ke switch.

Tugas :

  1. Gambarkan desain kondisi awal jaringan pada usaha game online tersebut
  2. Tata ulang konfigurasi jaringan tersebut dengan memperhatikan network availability, network performance dan network security berdasarkan pengelolaan perangkat layer-2 (Switch).
  3. Bagaimanakah manajemen pengalamatan dengan memperhatikan masalah broadcast traffic dan juga network security berdasarkan technology yang bisa di akomodasi oleh perangkat layer-3.

Penyelesaian :

1. Desain kondisi awal

 

Gambar-1 . Desain Awal Jaringan Game Online

2. Tata ulang konfigurasi jaringan tersebut dengan memperhatikan network availability, network performance dan network security berdasarkan pengelolaan perangkat layer-2 (Switch).

Gambar-2. Re-konfigurasi jaringan Game Online

Seperti terlihat pada gambar-2, bahwa penggunaan perangkat HUB seperti pada gambar-1 kurang tepat karena HUB tidak memiliki kemampuan dalam penanganan terhadap network collusion sehingga jika terjadi collusion di lantai 2 akan menggangu lantai 3 dan juga sebaliknya. Akan tetapi untuk lantai 1 tidak akan mengalami gangguan jaringan yang diakibatkan oleh terjadinya network collusion karena lantai 1 sudah menggunakan Switch. Penggunaan switch akan memberikan dampak terhadap peningkatan performance dan network security.

 

Jika menggunakan HUB, komunikasi yang dilakukan oleh salah satu terminal pada suatu port akan di teruskan ke semua port yang aktif pada HUB tersebut. Dengan demikian jika salah satu port yang ada di lantai 2 pada gambar 1 mengirimkan pesan ke port yang ada di lantai 2, maka semua port yang ada di lantai 2 dan semua port yang ada di lantai 3 akan mendapatkan paket pesan tersebut. Dengan demikian jika konfigurasi kita ubah seperti pada gambar-2 maka secara otomatis network performance jaringan game online tersebut akan meningkat. Dengan penggantian switch dengan konfigurasi seperti pada gambar 2, maka secara tidak langsung akan mengurangi resiko keamanan karena komunikasi yang dilakukan antar dua terminal tidak akan di kirimkan ke semua terminal, dengan demikian dengan konfigurasi seperti pada gambar-2 akan memberikan dampak terhadap perningkatan network security.

Untuk lebih meningkatkan pengamanan jaringan dengan menggunakan perangkat Switch, dapat dilakukan dengan mengkonfigurasi port masing-masing switch dengan port security. Dengan feature port security yang umumnya dimiliki oleh berbagai vendor switch manageble maka dapat diberikan batasan MAC Address dari komputer tertentu yang terdaftar saja yang bisa terkoneksi pada port tersebut. Bahkan bisa lebih maksimal lagi jika terjadi percobaan koneksi komputer yang tidak terdaftar pada port tersebut, port dapat langsung disabled secara otomatis. Dengan memaksimalkan kemampuan switch ini juga termasuk dalam peningkatan network security pada jaringan game online tersebut.

 

Sedangkan kaitannya dengan peningkatan network availability, dapat dilakukan dengan menyediakan 2 jalur koneksi antar switch yang umum dikenal dengan port switch redundancy link. Untuk bisa menggunakan konfigurasi redundancy link seperti pada gambar-2 tersebut, switch harus mempunyai kemampuan Spanning Tree Protocol (STP). Karena jika dua perangkat jaringan yang tidak memiliki kemampuan STP dipaksa di hubungkan dengan dua koneksi, maka akan mengakibatkan permasalahan baru di jaringan yakni broadcast storm, loop avoidance dan juga instability mac address tables. Dengan demikian pemasangan double konektifitas dalam menghubungkan dua switch dengan kemampuan STP, administrator jaringan sudah tidak perlu disibukan lagi dengan aktifitas disable/enable port yang menghubungkan 2 switch.

3. Bagaimanakah manajemen pengalamatan dengan memperhatikan masalah broadcast traffic dan juga network security berdasarkan technology yang bisa di akomodasi oleh perangkat layer-3.

Pembahasan :

Untuk menjawab kasus nomer 3 ini bisa tetap menggunakan bentuk konfigurasi seperti pada gambar 2, akan tetapi secara teknis harus dilakukan peningkatan pengaturan, atau switch manageable dengan membagi masing-masing lantai dengan VLAN. Pembagian tersebut untuk lantai 1 dapat ditentukan sebagai VLAN-10, lantai 2 sebagai VLAN-20 dan lantai-3 sebagai VLAN-30 beserta anggotanya berupa terminal-terminal yang ada di masing-masing lantai.

 

Pembuatan VLAN yang mengakibatkan jaringan lantai-1, 2 dan 3 menjadi terpisah maka harus dilakukan penggabungan kembali menggunakan router dengan menambahkan fungsi VLAN routing. Berkaitan dengan pembagian VLAN tiap lantai tersebut, berdampak terhadap perubahan pengalamatan pada jaringan. Misalnya awalnya jaringan dengan alamat 10.10.10.0/24 harus diubah menjadi 10.10.10.32/27 untuk 24 terminal di lantai 1(VLAN-10), 10.10.10.64/32 untuk VLAN-20, dan 10.10.10.96/27 untuk VLAN-30. Pengaturan pengalamatan 27 subnet bit tersebut didasarkan pada permasalahan pada kasus bahwa game online memiliki 42 terminal tersebar merata pada masing-masing lantai, maka pengaturan pengalamatan yang paling efficient adalah 25 untuk jumlah host bit nya, sehingga menghasilkan konfigurasi pengalamtan tersebut.

 

Dengan membagi jaringan dari 10.10.10.0/24 menjadi 3 subnet yakni 10.10.10.32/27, 10.10.10.64/27 dan 10.10.10.96/27 yang di pisahkan oleh VLAN untuk masing-masing segmen jaringannya yang di dihubungkan kembali (di filter) oleh router maka akan dapat mengurangi masalah network broadcast karena router tidak akan meneruskan network broadcast ke segmen jaringan lainnya. Secara tidak langsung juga akan meningkatkan keamanan atau network security karena pengguna di VLAN akan membatasi akses pengguna antar VLAN secara langsung. Sementara untuk lebih meningkatkan keamanan dengan memaksimalkan fungsi router yakni router access list atau kemampuan packet filter. Dengan network filter, dapat memblok akses atau bahkan jenis protokol dapat di batasi untuk masing-masing jaringan dan juga bisa juga per terminal berdasarkan alamat IP.

Sebagai contoh konfigurasi pada gambar-2 yang sudah menerapkan VLAN, port security, dan VLAN Routing seperti pada file yang dibuat dengan aplikasi Packet Tracer dengan konfigurasi sebagai berikut :

1. Konfigurasi VTP

VLAN

switch-1(config)#vlan 10

switch-1(config-vlan)#name vlan10

switch-1(config)#vlan 20

switch-1(config-vlan)#name vlan20

switch-1(config)#vlan 30

switch-1(config-vlan)#name vlan30

VLAN Trunking Protocol (VTP)

switch-1(config)#vtp domain stikom

switch-1(config)#vtp mode server

switch-2(config)#vtp domain stikom

switch-2(config)#vtp mode client

switch-3(config)#vtp domain stikom

switch-3(config)#vtp mode client

 

2. Konfigurasi VLAN & Port Security

SWITCH-1

interface FastEthernet0/1
switchport trunk allowed vlan 10,20,30
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
switchport port-security
switchport port-security maximum 4
switchport port-security violation protect
switchport port-security mac-address 0001.64B5.5976
!
interface FastEthernet0/3
switchport trunk allowed vlan 30
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk allowed vlan 30
switchport mode trunk
!
interface FastEthernet0/5
switchport trunk allowed vlan 20
switchport mode trunk
!
interface FastEthernet0/6
switchport trunk allowed vlan 20
switchport mode trunk

interface FastEthernet0/22
switchport access vlan 10
switchport mode access
switchport port-security
switchport port-security maximum 4
switchport port-security violation protect
switchport port-security mac-address 00E0.B07D.3B5A

SWITCH-2

interface FastEthernet0/1
switchport access vlan 20
switchport mode access
switchport port-security
switchport port-security violation protect
switchport port-security mac-address 0040.0B0C.C198
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
switchport port-security
switchport port-security violation protect
switchport port-security mac-address 0002.1724.0A92
!
interface FastEthernet0/5
switchport trunk allowed vlan 20
switchport mode trunk
!
interface FastEthernet0/6
switchport trunk allowed vlan 20
switchport mode trunk

SWITCH-3

interface FastEthernet0/1
switchport access vlan 30
switchport mode access
switchport port-security
switchport port-security violation restrict
switchport port-security mac-address 00E0.F708.6AD4
!
interface FastEthernet0/2
switchport access vlan 30
switchport mode access
switchport port-security
switchport port-security violation restrict
switchport port-security mac-address 0060.7050.5CAA
!
interface FastEthernet0/3
switchport trunk allowed vlan 30
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk allowed vlan 30
switchport mode trunk

ROUTER

interface FastEthernet0/0.1
encapsulation dot1Q 10
ip address 10.10.10.62 255.255.255.224
!
interface FastEthernet0/0.2
encapsulation dot1Q 20
ip address 10.10.10.94 255.255.255.224
!
interface FastEthernet0/0.3
encapsulation dot1Q 30
ip address 10.10.10.126 255.255.255.224

Tinggalkan Balasan

Please log in using one of these methods to post your comment:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: